FAQs
Mac Tips
Mac Shortcut Keys
Win Shortcut Keys
Product Registration
Suggestions
Bug reporting
Question?
Contacts
LaTeX Symbol Names
 
 
 

How can I select the non-editable Template body such as Integral, Fence, Fraction line, Accents, Embellishments, and so on?

Characters, symbols, and templates inserted in editable slots can be selected by mouse double-clicking or shift-arrow keys.
But those frame parts in some Templates, Accents or Embellishments, Slash or Negate bars can not be selected alone by the normal double-clicking or shift-arrows. This is limited intentionally by the MathMagic engine to reduce any unexpected changes of the selection and those parts are not necessarily to be changed in most cases.
However, if you have to select one of those parts for some reason, such as to apply Nudge or change Color or so, you can select it by clicking on it while pressing option key.
By the way, once a part is selected, you may apply a new Color, Size, Font, Style, and Nudge in general.

Can I re-edit or re-use the equations inserted in my word processor document or other application's documents?

If the equation is drag&droped to your destination document from MathMagic window, or copy&pasted, or exported & imported in either PICT or EPS format, the equation can be re-edited in most cases because these two formats embed and preserve the original MathMagic data as well. You can just drag(or copy&paste) the equation back to MathMagic window. But if the equation has been retouched by other application, the embeded MathMagic data might be lost and could not be re-edited by MathMagic.

Did you try Tripple-clicking or double Double-clicking?

You already know that double-clicking can select a continuous word. But MathMagic has further interactive interface for your enjoyable working experience. Triple-clicking will select the whole line in which the current box is located. But sometimes Triple-clicking can be way beyond your finger control or too much work for your lazy finger. In this case, you can just double-click and take some rest and then double-click again within the selected area. So twice of the Double-click with some interval will give you the same result with Triple-click.

What is the Magic key?

On the Mac, the Magic key is the control key. So it is often called "Magic Control key". It is similiar to the contextual key concept.
When you press the control key, MathMagic displays a shortcut tooltip on the Template or Symbol palettes and UserItem toolbar. With this Magic key interface, you can navigate all the Template or Symbol palettes and their buttons using keyboard strokes.
Once a palette is displayed, you can un-hold control key and then select a final button.

control-arrow key (left, right, up, down) navigate palettes to the direction.

control-Tab navigate palettes forward. control-shift-Tab rotates backward.

How can I move to the next slot?

Use the Tab Key when you want to move the cursor to the next slot, shift-Tab to the previous slot.

How can I move the cursor to the begining of a line or a document?

Command-Left Arrow key moves the cursor to the begining of the line. Command-Right Arrow key moves to the end of the line.
home and end key from the extended keyboard have the same result.

Command-Up Arrow key moves the cursor to the begining of the documment.
Command-Down Arrow key moves to the end of the document.
Command-home and command-end key from the extended keyboard have the same result.

Did you try command-G shourtcut key for Greek character input ?

All Greek characters can be easily typed via command-G followed by an alphabet key. Most of Greek keys are allocated with its corresponding Roman key.

Did you know that MathMagic support the wheel-mouse ?

MathMagic document windows, Clips window, and UserItem toolbar work with wheel-mouse for scrolling on Mac OS X.

Document window's horizontal scrolbar works with shift-wheel, if there are both horizontal & vertical scroll bars.

Did you try pressing the option key when closing a window ?

While pressing option key, if you click on the Close box of a document window, It will close all opened windows in turn.

You can also press option key when you close a floating Template or symbol palette, to close all opened palettes at once.

Did you know that you could set the default zoom for new editor windows?

The default zoom of new equation editor window is set to 300% in the Preferences->Misc. tab.
But you can change it to from 100% to 3200%. This value is stored in the MathMagic Pref file so that it can be applied to all of your new documents.

Can I hide all floating Templates & Symbol palettes at once ?

When there is one or more Template & Symbol palettes are displayed, clicking on Hide/Show palette from the Main toolbar will hide all the current Templates&Symbols palettes at once. If you press it again, it will bring all the palettes back at the same locations.

Did you try command-option-1 or command-option-2 ?

MathMagic will increase or decrease the zoom level of the front window from 100% to 3200%. So you don't need to use mouse.
Command-option-3 and Command-option-4 enable you increase zoom level by 10% and 1%.

Items in User Item toolbar can be rearranged.

You can drag a button to another place to rearrange the order. The new insertion point will be marked with a bold bar.

How can I add Template or Symbol buttons to the UserItem toolbar?

When a detached floating Tempate palette or Symbol palette is displayed, you can just drag a button from a Template palette or Symbol palette to the UserItem toolbar and drop it where you want it to insert.

If you want to add from a pop-up Tempate palette or Symbol palette, select a button while the command key(on Mac, alt key on Windows) is pressed. The button is added to the end of UserItem toolbar, instead of affecting the document.

How can I delete Template or Symbol buttons from the UserItem toolbar?

Or, just drag the button from the UserItem toolbar to the trash.

Just click the button that you want to remove with the command-key pressed.

How can I tell where the baseline is located for an equation?

There are a few ways of telling the baseline location. You can dispay the Baseline while editing equation by checking Show Baseline item from View menu. The red line is the master baseline of the full equation while the dotted red lines are baselines for each sub-line. This red line is for screen display only and not included in the exported equation. You can also make the baseline inserted in the exported equation by checking the Insert Baseline when Exporting item from View menu(available in v5.32 or later).
Another way is to see the Baseline offset value from the floating Size palette window as shown below, which can be opened from Window menu.


Copyright 1998-2017. InfoLogic, Inc. All rights reserved.
[ We proudly develop Quality Products]SM
Privacy Policy